Installation

Dependencies

Requirements:

  • Python 2.x (x>=6) or 3.x (x>=2)

  • PyQt4 4.x (x>=3 ; recommended x>=4) or PyQt5 5.x (x>=5)

  • QtPy >= 1.3

Optional Python modules:

  • spyder >=v2.0.10 for the test launcher and array/dictionnary editors

  • h5py (HDF5 files I/O)

  • cx_Freeze or py2exe (application deployment on Windows platforms)

Other optional modules for developers:

  • gettext (text translation support)

Installation

From the source package:

python setup.py install

Help and support

External resources:

  • Bug reports and feature requests: GitHub

  • Help, support and discussions around the project: GoogleGroup