GNU Image Manipulation Program

User Manual

Legal Notice

Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation; with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts. A copy of the license is included in the section enphrased GNU Free Documentation License.


Indice

Prefazione
1. Autori e collaboratori del manuale utente di GIMP
I. Introduzione
1. Introduction
1. Benvenuti a GIMP
1.1. Authors
1.2. The GIMP Help system
1.3. Features and Capabilities
2. Cosa c'è di nuovo in GIMP 2.10?
2.1. Updated user interface and initial HiDPI support
2.2. GEGL port, high bit depth support, multi-threading, and more
2.3. Linear color space workflow
2.4. Color management revamped
2.5. Layers and masks
2.6. More use for CIE LAB and CIE LCH
2.7. New and improved tools
2.8. Digital painting improvements
2.9. Digital photography improvements
2.10. Effects
2.11. Usability improvements
2.12. File formats support
2.13. Metadata viewing, editing, and preservation
2.14. On-canvas interaction
2.15. Simplified bug reporting and crash recovery
2.16. API changes
2.17. Roadmap and what's next
2. Fire up the GIMP
1. Eseguire GIMP
1.1. Known Platforms
1.2. Language
1.3. Command Line Arguments
2. Prima esecuzionde di GIMP
2.1. Finally . . .
3. First Steps with Wilber
1. Concetti base di GIMP
2. Le finestre principali in GIMP
2.1. Il pannello strumenti
2.2. Finestra immagine
2.3. Pannelli e finestre agganciabili
3. Annullamenti
3.1. Things That Cannot be Undone
4. Utilizzi frequenti
4.1. Intention
4.2. Change the Size of an Image for the screen
4.3. Change the Size of an Image for print
4.4. Compressing Images
4.5. Crop An Image
4.6. Find Info About Your Image
4.7. Change the Mode
4.8. Flip An Image
4.9. Rotate An Image
4.10. Separating an Object From Its Background
5. Come disegnare linee dritte
5.1. Intention
5.2. Examples
4. Getting Unstuck
1. Sbloccare la situazione
1.1. Stuck!
1.2. Common Causes of GIMP Non-Responsiveness
II. Come diventare un mago di GIMP?
5. Getting Images into GIMP
1. Tipi di immagine
2. Creazione di nuovi file
3. Aprire file esistenti
3.1. Open File
3.2. Open Location
3.3. Open Recent
3.4. Using External Programs
3.5. File Manager
3.6. Drag and Drop
3.7. Copy and Paste
3.8. Image Browser
6. Getting Images out of GIMP
1. File
1.1. Save / Export Images
1.2. File Formats
2. Preparare immagini per Internet
2.1. Images with an Optimal Size/Quality Ratio
2.2. Reducing the File Size Even More
2.3. Saving Images with Transparency
7. Painting with GIMP
1. La selezione
1.1. Feathering
1.2. Making a Selection Partially Transparent
2. Creazione e uso delle selezioni
2.1. Moving a Selection
2.2. Adding or subtracting selections
3. La maschera veloce
3.1. Overview
3.2. Properties
4. Uso della modalità maschera veloce
5. Tracciati
5.1. Path Creation
5.2. Path Properties
5.3. Paths and Selections
5.4. Transforming Paths
5.5. Stroking a Path
5.6. Paths and Text
5.7. Paths and SVG files
6. Pennelli
7. Aggiunta di nuovi pennelli
8. La finestra di dialogo GIH
9. Creazione di un pennello a dimensione variabile
9.1. How to vary the height of a brush
9.2. Creating a brush quickly
10. Gradienti
11. Motivi
12. Tavolozze
12.1. Colormap
13. Preimpostazioni
14. Disegno di oggetti semplici
14.1. Drawing a Straight Line
14.2. Creating a Basic Shape
8. Combining Images
1. Livelli
1.1. Layer Properties
2. Modalità del livello
3. Creazione di nuovi livelli
4. Gruppi di livelli
9. Text Management
1. Gestione del testo
1.1. Text Area
1.2. Managing Text Layer
1.3. Text Toolbox
1.4. Text Context Menu
2. Testo
2.1. Embellishing Text
2.2. Adding Fonts
2.3. Font Problems
10. Enhancing Photographs
1. Al lavoro con le fotografie digitali
1.1. Introduction
1.2. Improving Composition
1.3. Improving Colors
1.4. Adjusting Sharpness
1.5. Removing Unwanted Objects from an Image
1.6. Saving Your Results
11. Color Management with GIMP
1. Gestione del colore in GIMP
1.1. Problems of a non Color Managed Workflow
1.2. Introduction to a Color Managed Workflow
12. Enrich my GIMP
1. Preferences Dialog
1.1. Introduction
1.2. System Resources
1.3. Color Management
1.4. Playground
1.5. Tool Options
1.6. Default Image Preferences
1.7. Default Image Grid
1.8. Interface
1.9. Theme
1.10. Theme
1.11. Toolbox
1.12. Dialog Defaults
1.13. Help System
1.14. Display
1.15. Window Management
1.16. Image Windows
1.17. Image Window Appearance
1.18. Image Window Title and Statusbar
1.19. Image Window Snapping Behavior
1.20. Input Devices
1.21. Input Controllers
1.22. Folders
1.23. Data Folders
2. Griglie e Guide
2.1. The Image Grid
2.2. Guides
3. Disegnare una griglia
4. Come impostare la cache tile
5. Creazione di scorciatoie alle funzioni nei menu
6. Personalizza l'immagine d'avvio
13. Scripting
1. Plugin
1.1. Introduction
1.2. Using Plugins
1.3. Installing New Plugins
1.4. Writing Plugins
2. Uso degli script Script-Fu
2.1. Script-Fu?
2.2. Installing Script-Fus
2.3. Do's and Don'ts
2.4. Different Kinds Of Script-Fus
2.5. Standalone Scripts
2.6. Image-Dependent Scripts
3. Una guida sugli Script-Fu
3.1. Getting Acquainted With Scheme
3.2. Variables And Functions
3.3. Lists, Lists And More Lists
3.4. Your First Script-Fu Script
3.5. Giving Our Script Some Guts
3.6. Extending The Text Box Script
3.7. Your script and its working
III. Guida di riferimento di GIMP
14. Tools
1. La barra degli strumenti
1.1. Introduction
1.2. Tool Icons
1.3. Area dei colori e degli indicatori
1.4. Tool Options
2. Strumenti di selezione
2.1. Common Features
2.2. Rectangle Selection
2.3. Ellipse Selection
2.4. Free Selection (Lasso)
2.5. Fuzzy selection (Magic wand)
2.6. Select By Color
2.7. Intelligent Scissors
2.8. Foreground Select
3. Strumenti di disegno
3.1. Common Features
3.2. Dynamics
3.3. Brush Tools (Pencil, Paintbrush, Airbrush)
3.4. Bucket Fill
3.5. Gradient
3.6. Pencil
3.7. Paintbrush
3.8. MyPaint Brush
3.9. Eraser
3.10. Airbrush
3.11. Ink
3.12. Clone
3.13. Heal
3.14. Perspective Clone
3.15. Blur/Sharpen
3.16. Smudge
3.17. Dodge/Burn
4. Strumenti di trasformazione
4.1. Common Features
4.2. Align
4.3. Move
4.4. Crop
4.5. Rotate
4.6. Scale
4.7. Shear
4.8. Perspective
4.9. Unified Transform
4.10. Handle Transform
4.11. Flip
4.12. The Cage Tool
4.13. Warp Transform
5. Altri
5.1. Overview
5.2. Tracciati
5.3. Prelievo colore
5.4. Zoom
5.5. Misurino
5.6. Testo
5.7. Operazione GEGL
15. Dialogs
1. Introduzione alle finestre
2. Finestre relative alla struttura dell'immagine
2.1. Finestra livelli
2.2. Finestra di dialogo canali
2.3. Finestra di dialogo tracciati
2.4. Finestra mappa colori
2.5. Finestra dell'istogramma
2.6. Finestra di navigazione
2.7. Finestra cronologia annullamenti
3. Finestre relative al contenuto dell'immagine
3.1. La finestra di dialogo «Colore PP/SF»
3.2. Finestra di dialogo pennelli
3.3. Finestra motivi
3.4. Finestra di dialogo gradienti
3.5. Finestra di dialogo tavolozze
3.6. Marcatura
3.7. La finestra di dialogo caratteri
4. Finestre relative alla gestione delle immagini
4.1. Finestra di dialogo buffer
4.2. La finestra di dialogo immagini
4.3. Finestra cronologia documenti
4.4. La finestra di dialogo modelli
5. Finestre varie
5.1. Finestra di dialogo preimpostazioni strumenti
5.2. L'editor delle preimpostazioni degli strumenti
5.3. Finestra stato dispositivi
5.4. Console errori
5.5. Salva il file
5.6. Esporta file
5.7. Finestra «punti di campionamento»
5.8. Finestra «puntatore»
5.9. La finestra di dialogo di disegno simmetrico
16. Menus
1. Introduzione ai menu
1.1. The Image Menu Bar
1.2. Context Menus
1.3. Tear-off menus
1.4. Tab menus
2. Il menu «File»
2.1. Overview
2.2. New…
2.3. Create
2.4. Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Open Recent
2.8. Save
2.9. Save as…
2.10. Save a Copy…
2.11. Revert
2.12. Export…
2.13. Export As…
2.14. Create Template…
2.15. Print
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Close
2.20. Close all
2.21. Quit
3. Il menu «Modifica»
3.1. «Edit» Menu Entries
3.2. Undo
3.3. Redo
3.4. Fade
3.5. Undo History
3.6. Cut
3.7. Copy
3.8. Copy Visible
3.9. Paste
3.10. Paste Into Selection
3.11. Paste In Place
3.12. Paste Into Selection In Place
3.13. Paste as
3.14. Buffer
3.15. Clear
3.16. Fill with FG Color
3.17. Fill with BG Color
3.18. Fill with Pattern
3.19. Fill Selection Outline
3.20. Fill Path
3.21. Stroke Selection
3.22. Stroke Path
3.23. The «Preferences» Command
3.24. Keyboard Shortcuts
3.25. Modules
3.26. Units
4. Il menu «Seleziona»
4.1. Introduction to the «Select» Menu
4.2. Select All
4.3. None
4.4. Invert
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Remove Holes
4.15. Distort
4.16. Rounded Rectangle
4.17. Toggle QuickMask
4.18. Save to Channel
4.19. To Path
5. Il menu «Visualizza»
5.1. Introduction to the «View» Menu
5.2. New View
5.3. Dot for Dot
5.4. Zoom
5.5. Flip and Rotate (0°)
5.6. Shrink Wrap
5.7. Full Screen
5.8. Navigation Window
5.9. Display Filters
5.10. Color Management
5.11. Show Selection
5.12. Show Layer Boundary
5.13. Show Guides
5.14. Show Grid
5.15. Show Sample Points
5.16. Snap to Guides
5.17. Snap to Grid
5.18. Snap to Canvas
5.19. Snap to Active Path
5.20. Padding Color
5.21. Show Menubar
5.22. Show Rulers
5.23. Show Scrollbars
5.24. Show Statusbar
6. Il menu «Immagine»
6.1. Overview
6.2. Duplicate
6.3. Mode
6.4. RGB mode
6.5. Grayscale mode
6.6. Indexed mode
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Transform
6.15. Flip Horizontally; Flip Vertically
6.16. Rotation
6.17. Slice Using Guides
6.18. Canvas Size
6.19. Fit Canvas to Layers
6.20. Fit Canvas to Selection
6.21. Print Size
6.22. Scale Image
6.23. Crop Image
6.24. Zealous Crop
6.25. Merge Visible Layers
6.26. Flatten Image
6.27. Align Visible Layers…
6.28. Guides
6.29. New Guide
6.30. New Guide (by Percent)
6.31. New Guides from Selection
6.32. Remove all guides
6.33. Configure Grid…
6.34. Image Properties
7. Il menu «Livello»
7.1. Introduction to the «Layer» Menu
7.2. New Layer
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Anchor layer
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Discard Text Information
7.11. «Stack» Submenu
7.12. Select Previous Layer
7.13. Select Next Layer
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Raise Layer
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The «Reverse Layer Order» command
7.21. The «Mask» Submenu
7.22. Add Layer Mask
7.23. Apply Layer Mask
7.24. Delete Layer Mask
7.25. Show Layer Mask
7.26. Edit Layer Mask
7.27. Disable Layer Mask
7.28. Mask to Selection
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The «Transparency» Submenu of the «Layer» menu
7.33. Add Alpha Channel
7.34. Remove Alpha Channel
7.35. Color to Alpha
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The «Transform» Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Crop Layer
8. Il menu «Colori»
8.1. Introduction to the «Colors» Menu
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Saturation
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Invert
8.13. Linear Invert
8.14. Value Invert
8.15. The «Auto» Submenu
8.16. Equalizza
8.17. Bilanciamento del bianco
8.18. Aumento del colore
8.19. Aumento del colore (tradizionale)
8.20. Normalizza
8.21. Ampliamento contrasto
8.22. Ampliamento HSV
8.23. The «Components» Submenu
8.24. Mixer canali
8.25. Componi
8.26. Estrai componente
8.27. Mixer mono
8.28. Scomponi
8.29. Ricomponi
8.30. Da colore a grigio
8.31. Desatura
8.32. Seppia
8.33. The «Map» Submenu
8.34. Reimposta la mappa colori
8.35. Imposta mappa colori
8.36. Mappa aliena
8.37. Scambio colore
8.38. Ruota colori
8.39. Mappa gradiente
8.40. Mappa tavolozza
8.41. Colorazione a campione
8.42. Fattal et al. 2002
8.43. Mantiuk 2006
8.44. Reinhard 2005
8.45. Stress
8.46. Retinex
8.47. The «Info» Submenu
8.48. Istogramma
8.49. Media del bordo
8.50. Analisi cubocolori
8.51. Esporta istogramma
8.52. Sfuma tavolozza
8.53. Threshold
8.54. Colorize
8.55. Posterize
8.56. Color to Alpha…
8.57. Dither
8.58. RGB Clip
8.59. Hot…
9. Il menu «Strumenti»
9.1. Introduction to the «Tools» Menu
10. Il menu «Filtri»
10.1. Introduction to the «Filters» Menu
10.2. Repeat Last
10.3. Re-show Last
10.4. Reset All Filters
10.5. The «Python-Fu» Submenu
10.6. The «Script-Fu» Submenu
11. Il menu «Finestre»
12. Il menu «Aiuto»
12.1. Introduction to the «Help» Menu
12.2. Help
12.3. Context Help
12.4. Tip of the Day
12.5. About
12.6. Plug-In Browser
12.7. The Procedure Browser
12.8. GIMP online
17. Filters
1. Introduzione
2. Caratteristiche comuni
3. Filtri di sfocatura
3.1. Introduction
3.2. Gaussian Blur
3.3. Median Blur
3.4. Pixelize
3.5. Selective Gaussian Blur
3.6. Circular Motion Blur
3.7. Linear Motion Blur
3.8. Zoom Motion Blur
3.9. Tileable Blur
4. Filtri di miglioramento
4.1. Introduction
4.2. Antialias
4.3. Deinterlace
4.4. High Pass
4.5. Noise Reduction
4.6. Red Eye Removal
4.7. Symmetric Nearest Neighbor
4.8. Sharpen (Unsharp Mask)
4.9. Despeckle
4.10. Destripe
4.11. NL Filter
4.12. Wavelet Decompose
5. Filtri di distorsione
5.1. Introduction
5.2. Apply Lens
5.3. Emboss
5.4. Engrave
5.5. Lens Distortion
5.6. Mosaic
5.7. Polar Coordinates
5.8. Ripple
5.9. Shift
5.10. Spherize
5.11. Value Propagate
5.12. Video
5.13. Waves
5.14. Whirl and Pinch
5.15. Wind
5.16. Curve Bend
5.17. Emboss (legacy)
5.18. Newsprint
5.19. Page Curl
6. Filtri luce e ombra
6.1. Introduction
6.2. Supernova
6.3. Lens Flare
6.4. Gradient Flare
6.5. Lighting Effects
6.6. Sparkle
6.7. Drop Shadow
6.8. Long Shadow
6.9. Vignette
6.10. Drop Shadow
6.11. Perspective
6.12. Xach-Effect
7. Filtri di disturbo
7.1. Introduction
7.2. CIE lch Noise
7.3. HSV Noise
7.4. Hurl
7.5. Pick
7.6. RGB Noise
7.7. Slur
7.8. Spread
8. Filtri di rilevamento contorni
8.1. Introduction
8.2. Difference of Gaussians
8.3. Edge
8.4. Laplace
8.5. Neon
8.6. Sobel
9. Filtri generici
9.1. Introduction
9.2. Convolution Matrix
9.3. Distance Map
9.4. GEGL graph
9.5. Dilate
9.6. Erode
10. Filtri di combinazione
10.1. Introduction
10.2. Depth Merge
10.3. Filmstrip
11. Filtri artistici
11.1. Introduction
11.2. Apply Canvas
11.3. Cartoon
11.4. Cubism
11.5. Glass Tile
11.6. Oilify
11.7. Photocopy
11.8. Simple Linear Iterative Clustering (SLIC)
11.9. Softglow
11.10. Waterpixels
11.11. Cartoon (legacy)
11.12. Clothify
11.13. GIMPressionist
11.14. Oilify (legacy)
11.15. Predator
11.16. Softglow (legacy)
11.17. Van Gogh (LIC)
11.18. Weave
12. Decorazioni
12.1. Introduction
12.2. Add Bevel
12.3. Add Border
12.4. Coffee Stain
12.5. Fog
12.6. Fuzzy Border
12.7. Old Photo
12.8. Round Corners
12.9. Slide
12.10. Stencil Carve
12.11. Stencil Chrome
13. Filtri mappa
13.1. Introduction
13.2. Bump Map
13.3. Displace
13.4. Fractal Trace
13.5. Illusion
13.6. Little Planet
13.7. Panorama Projection
13.8. Recursive Transform
13.9. Paper Tile
13.10. Tile Seamless
13.11. Fractal Trace (legacy)
13.12. Map Object
13.13. Tile
14. Filtri Render
14.1. Introduction
14.2. Flame
14.3. Fractal Explorer
14.4. IFS Fractal
14.5. Cell Noise
14.6. Perlin Noise
14.7. Plasma
14.8. Simplex Noise
14.9. Solid Noise
14.10. Difference Clouds
14.11. Checkerboard
14.12. Diffraction Patterns
14.13. Grid
14.14. Maze
14.15. Sinus
14.16. Checkerboard (legacy)
14.17. CML Explorer
14.18. Grid (legacy)
14.19. Jigsaw
14.20. Qbist
14.21. Circuit
14.22. Gfig
14.23. Lava
14.24. Line Nova
14.25. Sphere Designer
14.26. Spyrogimp
15. Filtri Web
15.1. Introduction
15.2. ImageMap
15.3. Semi-Flatten
15.4. Slice
16. Filtri di animazione
16.1. Introduction
16.2. Blend
16.3. Burn-In
16.4. Rippling
16.5. Spinning Globe
16.6. Waves
16.7. Optimize
16.8. Playback
I. Indice di riferimento tasti
Help — Key reference for Help menu
Tools — Key reference for the Tools menu
File — Key reference for the File menu
Dialogs — Key reference for Dockable Dialogs submenu
View — Key reference for View menu
Edit — Key reference for Edit menu
Layer — Key reference for Layer menu
Select — Key reference for Select menu
Filters — Key reference for Filters menu
Zoom tool — Key reference for the Zoom tool submenu
Glossario
Bibliografia
A. La storia di GIMP
1. The Very Beginning
2. The Early Days of GIMP
3. The One to Change the World
4. Versione 2.0
5. Cosa c'è di nuovo in GIMP 2.2?
6. Cosa c'è di nuovo in GIMP 2.4?
7. Cosa c'è di nuovo in GIMP 2.6?
8. Cosa c'è di nuovo in GIMP 2.8?
B. Segnalazione difetti e richieste di miglioramenti
1. Making sure it's a Bug
2. Reporting the Bug
3. What Happens to a Bug Report after you Submit it
C. Come contribuire
1. Prerequisites
1.1. Join our mailing list
1.2. Create a Local Working Copy of Code
1.3. Installing your sandbox
1.4. The gimp-help folder
2. Workflow
2.1. Writing
2.2. Validating
2.3. Images
2.4. Create HTML Files
2.5. Sending your files
3. Annexes
4. Working under Windows
4.1. Adapting Cygwin to use with GIMP documentation tools
D. Mappatura tonale e recupero ombre usando le funzioni ‘Colori/Esposizione’ di GIMP
1. High bit depth GIMP’s floating point “Colors/Exposure”: much better than Curves for lightening the shadows and midtones of an image without blowing the highlights
2. A step-by-step example showing how to recover shadow information using high bit depth GIMP’s floating point “Colors/Exposure”
3. Use Notes
4. Conclusion
E. Licenza di documentazione libera del progetto GNU
1. PREAMBLE
2. APPLICABILITY AND DEFINITIONS
3. VERBATIM COPYING
4. COPYING IN QUANTITY
5. MODIFICATIONS
6. COMBINING DOCUMENTS
7. COLLECTIONS OF DOCUMENTS
8. AGGREGATION WITH INDEPENDENT WORKS
9. TRANSLATION
10. TERMINATION
11. FUTURE REVISIONS OF THIS LICENSE
12. ADDENDUM: How to use this License for your documents
F. Oops! Manca un file di aiuto!
Indice analitico